Page 1 of 1

[Success] SierraAMD v5 - FX-6300 - ASUS M5A97 LE R2.0 - nVidia GTX 970 - Alongside existing Windows

PostPosted:Thu Oct 12, 2017 8:45 pm
by ShiningWing
It works! Sweet! Thanks a bunch to Norton287, without his help I wouldn't have figured out how to proceed! :thumbup:

Rough installation process (pretty far from how I ended up doing it, but if I was to do it again here's how I'd do it):

1. Convert Windows hard disk from MBR to GPT using the built-in MBR2GPT tool (comes with Windows 10 Creator's Update), then set the BIOS to boot from UEFI
2. Using Paragon Partition Manager, shrink the partition size of the Windows partition and create a new HFS+ partition in the empty space
3. Use TransMac to restore SierraAMD_v5.dmg to my flash drive
4. Insert it into the computer and boot into Clover and selecting SierraAMD, taking the drive out and putting it back in once the verbose log text comes up
5. Install macOS Sierra normally
6. On reboot, repeat booting the SierraAMD Installer and open the terminal, running the post-install process
7. Using the flash drive once again, boot Clover but select the hard drive
8. Use the Terminal to mount the EFI partition (in my case, running "diskutil mount disk0s3")
9. Open the Clover folder on the EFI partition, and set it up with the files it put on the root of the macOS partition
10. On the EFI disk, go to [EFI Partition]/EFI/Microsoft/Boot/ and rename bootmgfw.efi to bootmgfw-orig.efi (This causes the UEFI loader to load Clover instead of Windows)
11. Reboot, and on boot install nVidia Web Drivers, as well as the VoodooHDA and Realtek ethernet kexts
12. Reboot, removing the "nv_disable=1" from the boot flags, then on boot run Clover Configurator and make the appropriate tweaks

Current issues:
  • The graphics card seems to not be running at full power. Attempting to run the Firestorm Viewer for Second Life results in it running very slowly. There's also graphics lag here and there. However, this usually isn't a problem for apps like Pages and Sketch, as well as general web browsing. Blurred transparent effects also work. I'm currently trying to figure this out.
  • I plugged in a USB mic (Blue Snowball ICE) and set it as my default audio input, with the purpose of using it with Siri. However, it doesn't seem to want to work. Similarly, when using it in GarageBand, I get "Error while trying to synchronize Audio and MIDI. Sample Rate 37,651 recognized. Check conflict between GarageBand and external device." This happens regardless of how I set it in Audio MIDI Setup.
  • Inactive buttons in the toolbar (as well as ones I'm holding the toolbar on) are invisible. I have no idea why, I'm also trying to figure this one out.
  • When the system goes to sleep, I can't seem to wake it up. It usually just goes right back to sleep before anything even shows up on the display. I don't really use sleep mode though, so it's not a big deal.
I'm currently trying to figure out these issues, but otherwise it works pretty well! It's pretty nice to use Sketch compared to Inkscape (though I still have to get used to it), and Safari's not that bad. Plus, I didn't have to get rid of my Windows installation and it's programs and games! I can boot to Windows right from Clover, and it all works great. :D